Zurück zu Willert.de

Migrating Legacy Code from Rhapsody 5.0.1 to 7.4

For questions around OS environment, the OXF or RTOS Adapter Layer

Migrating Legacy Code from Rhapsody 5.0.1 to 7.4

Postby ofpteam » April 27th, 2011, 7:40 am

I am working with Rhapsody in C++ version 7.4.

Anyone, plz guide me on follwoing:

1. As I understand the way to handle unconsumed events is to override the handleNotConsumed() method of OMReactive in my own reactive class. However, this method is not declared as virtual in the framework source code. Is it a bug or intentional. And what is the proper method of handling unconsumed events in the framework. (NOTE: In a previous version of Rhapsody that I used, the method handleEventNotConsumed() was declared virtual in the framework.)

2. When I try to generate code (using Rhapsody 7.4) from a model originally built in Rhapsody 5.0.1, do the necessary changes in code according to the new framework methods such as overriding handleNotConsumed etc and then try to download and execute on a vxworks target, it crashes and the target reboots. Plz, anyone has any idea if it is due to the framework change, because otherwise the code was working fine on the same target and the same OS ie vxWorks.

Regards.
ofpteam
 
Posts: 1
Joined: November 21st, 2010, 8:55 am

Return to Framework

Who is online

Users browsing this forum: No registered users and 3 guests

cron