Zurück zu Willert.de

WSTDeployer and 64 Bit Systems

For questions around OS environment, the OXF or RTOS Adapter Layer

WSTDeployer and 64 Bit Systems

Beitragvon eroemer » März 27th, 2014, 6:20 pm

Unfortunately using a combination of IBM Rational Rhapsody and the Willert Software Tools RXF under 64 Bit environments is not always as smooth as it should be.

The main difficulty here is the Java interface for the Rhapsody-API, which is used by the WSTDeployer. It accesses Rhapsody.jar, which is installed along with the Rhapsody user data files (e.g. in "C:\Users\<username>\IBM\Rational\Rhapsody\<version>\Share\JavaAPI").

If Rhapsody 32-Bit is installed, the rhapsody.jar needs to be accessed with a 32-Bit Java Runtime Environment (JRE). The Rhapsody 64-Bit version makes the use of a 64-Bit JRE necessarry.

Using inproper bit-version combinations can cause error messages like:
Code: Alles auswählen
Exception in thread "main" java.lang.UnsatisfiedLinkError: <path>\rhapsody.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform


In our experience the following setups are unproblematic and without pitfalls:
  • Windows 7 32-Bit
  • Java Runtime Environment 32-Bit
  • IBM Rational Rhapsody 32-Bit
or
  • Windows 7 64-Bit
  • Java Runtime Environment 32-Bit
  • IBM Rational Rhapsody 32-Bit

We currently do not recommend using Rhapsody 64-Bit Editions. With the right 64-Bit JRE they work together with the Willert Deployer just fine, but also other extensions or plugins still seem to cause problems.

It is possible to have both, the 32-Bit and 64-Bit JRE installed in parallel on a Windows 64-Bit machine. In that case the safest way to make sure the WSTDeployer uses the correct JRE-Version is to edit WSTDeployer.bat. It can be found at: "<Willert folder>\<RXF release name>\Tools\WSTDeployer\WSTDeployer.bat". In that file modify the call of "java" by adding the abolute path to the matching bit version of the JRE. For example: "C:\Program Files\Java\jre7\bin\java.exe". Make sure to use quotes, if the path contains space characters.
Benutzeravatar
eroemer
 
Beiträge: 9
Registriert: Oktober 14th, 2011, 10:16 am
Wohnort: Bremen
Firma: Willert Software Tools GmbH

WSTDeployer and 64 Bit Systems

Beitragvon EvaNap » Februar 1st, 2018, 8:12 am

This is the same error with my system.
Now it is fixed. I just changed the location and there was no error
EvaNap
 
Beiträge: 1
Registriert: Januar 29th, 2018, 12:46 am
Firma: google


Zurück zu Framework

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron